Email delivery delayed
Incident Report for imgix
Resolved
Delays in email sending have been resolved, but if you requested an email that you have not received, please try again.
Posted 6 months ago. Mar 06, 2019 - 14:17 PST
Monitoring
Password reset and new sign-up emails are now being sent successfully. If you have previously requested an email but have not received it, please try requesting again. If you need any assistance, contact support@imgix.com.
Posted 6 months ago. Mar 06, 2019 - 12:40 PST
Identified
We've identified an issue with our email provider. Password reset emails & new account signups are currently delayed. Please contact support@imgix.com if you need assistance accessing your imgix account.
Posted 6 months ago. Mar 06, 2019 - 12:26 PST
This incident affected: Web Administration Tools.