Encoding Error for Web folder
Incident Report for imgix
Postmortem

Postmortem

What happened?

On January 22, 2024, 07:38 UTC, some Web Folder requests to the imgix service began to return a 403 response. 

By 11:56 UTC, the issue had been completely resolved.

How were customers impacted?

Between 07:38 UTC and 11:36 UTC, several requests to web folder sources began to return a 403 error. This affected a small amount of assets (<0.1%). 

What went wrong during the incident?

A service update caused an issue with web folders with directories using double slashes at the Origin URL (//). This update caused an encoding error, leading to 403 responses for Origins matching the double slash pattern. A fix was pushed to resolve this URL pattern, allowing us to fetch images from affected Origins.

What will imgix do to prevent this in the future?

We will update our tests to catch encoding issues in the future.

Posted Feb 26, 2024 - 09:42 PST

Resolved
We have identified the issue and are currently applying a fix.

The rendering service is not affected.
Posted Jan 22, 2024 - 13:00 PST