Investigating issues with changing account plans

Incident Report for imgix

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 10:58 PDT

Investigating

We are investigating issues with upgrading/downgrading account plans through the dashboard. In the meantime, please reach out to our support team if you need to change your plan.
Posted Oct 28, 2025 - 10:48 PDT
This incident affected: Web Administration Tools.