Investigating errors with plan upgrades through the dashboard.

Incident Report for imgix

Resolved

This incident has been resolved.
Posted Jan 26, 2026 - 16:58 PST

Identified

We are investigating a billing issue with upgrading plan types. If you need to upgrade your plan, please reach out to support as a workaround.
Posted Jan 26, 2026 - 08:15 PST
This incident affected: Web Administration Tools.