Billing display issue
Incident Report for imgix
Resolved
This incident has been resolved.
Posted Jul 12, 2022 - 15:55 PDT
Identified
We are fixing a display issue affecting some of our user's billing overview dashboards. For correct billing information, please visit the invoices page: https://dashboard.imgix.com/invoices
Posted Jul 11, 2022 - 21:35 PDT
This incident affected: Web Administration Tools.