Elevated rendering errors
Incident Report for imgix
Postmortem

What happened?

On September 12, 2024, imgix deployed a change to optimize image delivery for Safari browsers. This update inadvertently impacted a small number of browsers by delivering image formats they could not display. imgix identified the issue on September 14 and rolled back the changes to prevent further impact.

How were customers impacted?

Between September 12 and 14, 2024, customers using certain older browsers may have experienced issues displaying images. These users may have encountered image errors, while modern browsers, including Safari, continued to display images as expected.

What went wrong during the incident?

An update meant to optimize image delivery for Safari browsers was applied too broadly. As a result, some browsers not fully compatible with the AVIF image format served these files, causing display issues and affecting approximately 0.02% of renders.

What will imgix do to prevent this in the future?

To prevent similar issues, imgix will implement the following measures:

  • More Precise Targeting: Future updates will be more carefully targeted to specific browsers, ensuring only those that can handle advanced image formats like AVIF receive them.
  • Enhanced Compatibility Checks: We are improving browser compatibility checks to ensure the correct image formats are delivered based on the browser's capabilities.
  • Continued Monitoring: We will closely monitor image delivery performance to detect any compatibility issues early and ensure all users have a seamless experience.

These actions will help us deliver a more reliable and optimized experience for all of our customers.

Posted Sep 24, 2024 - 15:38 PDT

Resolved
We have resolved the issue where some browsers received unsupported image formats, affecting a small number of renders. The changes have been rolled back, and services are fully restored
Posted Sep 12, 2024 - 21:48 PDT
This incident affected: Rendering Infrastructure.